用户工具

站点工具


vhall_open:sdk使用准备

SDK使用准备

1、下载SDK&DEMO

2、开发环境要求

最低支持iOS版本:iOS 7.0

最低支持iPhone型号:iPhone 5

支持CPU架构: armv7, arm64

含有i386和x86_64模拟器版本的库文件,推流功能无法在模拟器上工作,播放功能完全支持模拟器。

3、ATS支持情况

支持

4、添加依赖库

添加系统库

libc++.tbd

libz2.1.0.tbd

libicucore.tbd

libz.tbd

libiconv.tbd

CoreTelephony.framework

MediaPlayer.framework

AVFoundation.framework

VideoToolbox.framework

AssetsLibrary.framework

OpenAL.framework

OpenGLES.framework

QuartzCore.framework

CoreMedia.framework

Security.framework

JavaScriptCore.framework

将VHallSDK文件夹添加到工程中,添加后的效果如下图所示:

vhall_open/sdk使用准备.txt · 最后更改: 2017/09/29 15:43 由 yan.gao